Civilization V Multiplayer Issue

Gather resources, build your army, conquer!
Forum rules

1) This is a Christian site, respect our beliefs and we will respect yours.

2) This is a family friendly site, no swearing or posting offensive links, pictures, or signatures.

3) Please be respectful of others.

4) Trolls are not welcome and will be dealt with accordingly.

5) No racial comments, jokes or images

6) If you see a dead thread over 6 months old, let it rest in peace

7) No Duplicate posts
User avatar
Kwan
Senior Member
Senior Member
Posts: 340
Joined: Sat Mar 30, 2013 4:37 am
Are you human?: Yes!
Location: WA

Civilization V Multiplayer Issue

Postby Kwan » Thu Apr 03, 2014 4:09 am

I have been playing a game with a friend and everything has gone fine until recently it makes us reconnect after every second turn (shows the loading screen which takes about a minute each time). We are on a large map (8 AI + us 2), have done more then 250 turns, are using no DLC, and are playing via Steam connection. I've looked around for some help, but I haven't really found much except that our world might be too big or that we should use a VNP (which I am not going to do). I have also heard that Brave New Worlds improves the multiplayer, but I am not sure if it is talking about the bugs or just general improvements. Thank you for reading.

User avatar
ArchAngel
CCGR addict
Posts: 3547
Joined: Tue May 31, 2005 12:00 am
Location: San Jose, CA

Re: Civilization V Multiplayer Issue

Postby ArchAngel » Thu Apr 03, 2014 3:56 pm

I haven't run into that issue, so I can't say. Are you playing over a local network or internet?
Pew Pew Pew. Science.

RoA: Kratimos/Lycan
UnHuman: Tim

User avatar
Kwan
Senior Member
Senior Member
Posts: 340
Joined: Sat Mar 30, 2013 4:37 am
Are you human?: Yes!
Location: WA

Re: Civilization V Multiplayer Issue

Postby Kwan » Thu Apr 03, 2014 8:49 pm

I haven't run into that issue, so I can't say. Are you playing over a local network or internet?
Internet

User avatar
TDog9631
Regular Member
Regular Member
Posts: 148
Joined: Thu Jan 09, 2014 12:49 am
Location: Houston Texas

Re: Civilization V Multiplayer Issue

Postby TDog9631 » Thu Apr 03, 2014 10:33 pm

I think I found your problem
http://forums.2k.com/showthread.php?143 ... -each-turn" onclick="window.open(this.href);return false;
Steam: bE.(Insert witty name) Origin: TDog9631 Battle.net:TDog9631#1737


Return to “Strategy”

Who is online

Users browsing this forum: No registered users and 1 guest

cron